blank
< zurück

This article provides an overview of the minimum requirements that must be met in order to run NoSpamProxy.

Note: In order for you to receive support services,

  • the listed requirements must be fulfilled and
  • a corresponding manufacturer support contract must be in effect.

We do not guarantee the completeness of the following information on third-party products. In any case, make sure to check the manufacturer’s pages for updates!

General requirements

  • A corporate email server, either in the company network or in the cloud.
  • NoSpamProxy can NOT be operated using the combination “Domain Controller + Exchange + NoSpamProxy” on one single system, because the operation of Exchange on a domain controller is prohibited. See Exchange Server Supportability Matrix.
  • NoSpamProxy can be installed on a system in parallel with the email server. However, this combination is not recommended, because of duplicate port assignments (mostly ports 25, 443 and 6060/6061), which can cause problems during operation. We recommend to always change the ports of the email server in case of parallel operation, so that NoSpamProxy can be reached from outside via the standard ports.

NoSpamProxy uses the following standard ports:

  • Port 6060/6061 TCP
    • internal communication between the Intranet Role and the Gateway Roles
  • Port 25 TCP
    • SMTP
    • inbound and outbound
    • modifyable
    • also used by Exchange during parallel operation
  • Port 443 TCP
    • SSL
    • internal and external communication with the Web Portal
    • modifyable
  • Port 465 TCP
    • POP3
    • to retrieve POP3 messages
    • no support for NoSpamProxy Protection

Hardware requirements

The following specifications are minimum requirements. The recommended configuration depends on the email volume and the use of individual NoSpamProxy functions.

  • 4GB RAM
  • 2 processor cores
    • virtualized or physical
  • Hard disk space
    • should be discussed individually with the support or presales team
    • If Intranet and Gateway Role are operated on one single system with no Web Portal present, 100GB should be sufficient.

Supported NoSpamProxy versions

The following versions are currently covered by our support:

  • Version 13.2
  • Version 13.1
  • Version 13.0
  • Version 12.2
  • Version 12.1 (no longer supported with release of version 14)
  • Version 12.0 (no longer supported with release of version 14)
  • Version 11.1 (no longer supported with release of version 14)

NoSpamProxy Outlook Add-In

  • Outlook 2010 and later

Microsoft Operating Systems

  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012 (no longer supported with version 14)
  • Microsoft Windows Server 2008 R2 (no longer supported with version 14)

Microsoft .NET Framework

  • .NET Framework 4.8, supported as of NoSpamProxy version 13, mandatory as of version 14
  • .NET Framework 4.7.2, mandatory supported from NoSpamProxy 12.2 onwards
  • .NET Framework 4.6.2, supported up to version 12.1 and older
  • .NET Framework 4.5.7, supported up to version 11.1 and older

Microsoft SQL Server Express Version

  • Microsoft SQL Server 2019 Express Version (supported for Windows Server 2016 and above)
  • Microsoft SQL Server 2017 Express Version (supported for Windows Server 2012 R2 and Windows Server 2016)
  • Microsoft SQL Server 2014 Express Version (no longer supported with version 14)
  • Microsoft SQL Server 2012 Express Version (no longer supported with version 14)
  • Microsoft SQL Server 2008 R2 Express Version (no longer supported with version 14)

For details on supported combinations, please refer to the official Microsoft pages for each product.

Microsoft SQL-Server Standard/Enterprise

  • Microsoft SQL-Server 2012 SP4 and later
  • Microsoft SQL-Server 2012 SP3 and older (no longer supported with version 14)

Microsoft Report Viewer

Microsoft Report Viewer 2010 is required to install the Intranet Role.

Microsoft Visual Studio Tools for Office

Visual Studio Tools for Office 2010 Runtime or higher is required to install the Outlook Add-In.

Further notes

  • Make sure that any third-party applications you use that connect to NoSpamProxy are covered by their respective manufacturer’s support. If this is not the case, the NoSpamProxy support team will not be able to provide support.
  • Make sure that the necessary exceptions are set in the local Windows Defender (and other AV scanners used) to allow NoSpamProxy to run smoothly.
  • If you have installed NoSpamProxy and Microsoft Exchange on the same server, make sure that the respective version of the framework is supported by Exchange before installing or updating the Microsoft .NET framework. An overview of supported versions is provided in the Exchange Server Supportability Matrix.
  • Further details about the installation of the add-in can be found in the Outlook Add-In Installation and Group Policy manual. There, the installation with the MSI file for software distributions is also addressed.